?

Log in

No account? Create an account

Изменяю своим привычкам


Previous Entry Share Next Entry
Сети для самых маленьких. Часть третья. Статическая маршрутизация
eucariot

Ретроспектива


2. Сети для самых маленьких. Часть вторая. Коммутация
1. Сети для самых маленьких. Часть первая (которая после нулевой). Подключение к оборудованию cisco
0. Сети для самых маленьких. Часть нулевая. Планирование

Итак, поворотный момент в истории компании “Лифт ми Ап”. Руководство понимает, что компания, производящая лифты, едущие только вверх, не выдержит борьбы на высококонкурентном рынке. Необходимо расширять бизнес. Принято решение о покупке двух заводов: в Санкт-Петербурге и Кемерово.
Нужно срочно организовывать связь до новых офисов, а у вас ещё даже локалка не заработала.
Сегодня:
1. Настраиваем маршрутизацию между вланами в нашей сети (InterVlan routing)
2. Пытаемся разобраться с процессами, происходящими в сети, и что творится с данными.
3. Планируем расширение сети (IP-адреса, вланы, таблицы коммутации)
4. Настраиваем статическую маршрутизацию и разбираемся, как она работает.
5. Используем L3-коммутатор в качестве шлюза



Read more...Collapse )

Здравствуйте. Меня зовут Денис. Спасибо за цикл статей. Я как раз и есть "новичковый" новичок. Готовлюсь к сдачи CCNA. К сожалению, не могу разобраться с Вашим заданием: почему не пингуются устройства из сети управления.
По отдельности любой из хостов каждой подсети пингует свой шлюз: например PTO - 172.16.3.1, managment - 172.16.1.1. Хост из подсети 172.16.3.0 даже пингует шлюз подсети управления 172.16.1.1, но ни один другой коммутатор ( 172.16.1.2, 172.16.1.3 и т.д.). Проблема не в маршрутизаторе - иначе не было бы связи между остальными подсетями (PTO и FEO или OTHER). Но ведь устройства в каждой подсети прекрасно пингуют хосты из другой подсети , за исключение сети управления.
При этом я подсоединил к одному из коммутаторов хост с ip-адресом принадлежащим сети управления: 172.16.1.8, настроил access порт на коммутаторе и этот хост прекрасно пингуется с другими подсетями -но ведь он в сети управления и из других подсетей он прекрасно пингуется.
Проблема в виртуальных интерфейсах коммутаторов? Но ведь у каждого свой mac и ip адреса. И в пределах своей подсети они пингуются.
Или у виртуальному интерфейсу нужно сопоставить access порт, что по видимому невозможно?
Простите за сумбурность вопросов.
С уважением, Денис

Вопросы не сумбурные, понятные, Денис. Я задам вам наводящий вопрос: пингуются ли с коммутатора устройства других вланов?
Вы правильно поняли, что проблема не в маршрутизаторе - в коммутаторах.
Что вы настраиваете на компьютерах и не настроили на коммутаторах?

Похоже на коммутаторе не настроил шлюз, что я делал на компьютере

Все правильно. Добавил командой ip default-gateway 172.16.1.1 и все заработало.
Спасибо.

Еще раз хочу выразить благодарность за статьи. Отлично написано, очень ясно, просто, и при этом максимально полезно. Использую как практическую базу при прочтении official exam certification guide, особенно главы switch configuration, routing configuration
С уважением

Пожалуйста. Оставайтесь на связи. В скором времени 5-ая часть про ацл, а также подкаст для связистов. Будет интересно. Если оставите свою почту, смогу вас предупредить об этом.

С удовольствием оставлю: denis101@sura.ru.

Договорились)

Здравствуйте! Не переживайте, что вас не читают новички и студенты, читают еще как! Я вот уже недели полторы осваиваю ваши статьи, разбираю по кусочкам и рисую схемы в PT, все работает, все поднимается!
Спасибо большое за такой курс! Мне он попался так вовремя, теоретические рваные знания у меня есть. А вот такой пост, где собрано все воедино на практике и показано что и зачем нужно встречаю впервые и очень рада - это талантище просто! Вам бы преподавать в университете, а то мне даже крохи от этого всего не рассказали, полгода об OSI рассказывали, в итоге забила на пары и сама читала.
Никогда не комментила статьи, но тут особый случай. Спасибо еще раз, а то столько комментариев вижу от вас, о том, что вы бы хотели увлекать новичков, поэтому решила хоть раз написать - у вас это получается!

Ах, бальзам на душу. Рад, что вам это помогает. Задавайте вопросы)

Спасибо большое за цикл статей. Заставил задуматься ваш вопрос о том почему не отвечают устройства в управляющем vlan`е %)) При этом сам имел опыт напарывать на подобную проблему, когда настраиваешь управление л2 в удаленную точку и забываешь указать ip def-gw, а затем едешь и с порта с управлением на месте (который не забываю настраивать) - делаешь нужное.

Пожалуйста)
Только почему вы не можете зайти на другое устройство из той же сети и уже с него на проблемное?

Здравствуйте! Очень понравился ваш цикл статей! Буквально заглотил его за неделю =) Как раз начался курс сетей в университете и тут такое хорошее дополнение.

Сегодня дошел до 4й части и столкнулся с проблемой при конфигурировании сети в "Озерках". А именно при добавлении L3 коммутатора, настроена сеть LAN, но никак не могу добиться видимости из нее, да и с самого коммутатора маршрутизатора spb-vsl-gw1. Пинг с коммутатора на адрес 172.16.2.5 идет, а на 172.16.16.1 нет =( Все перепроверял уже, конструировал маленькие аналоги, однако безуспешно =( Голова кипит просто уже >_<

Будьте добры, подскажите наводкой что я сделал не так. Заранее спасибо =)

Файл PT: http://ge.tt/7IhAp5I/v/0?c

Конфиг spb-ozerki-gw1

Gateway of last resort is 172.16.2.5 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.2.4/30 is directly connected, FastEthernet0/24
C 172.16.17.0/24 is directly connected, Vlan2
S* 0.0.0.0/0 [1/0] via 172.16.2.5

interface FastEthernet0/1
description Pupkin
switchport access vlan 2
switchport mode access

interface FastEthernet0/24
no switchport
ip address 172.16.2.6 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description VLAN
ip address 172.16.17.1 255.255.255.0
!


И таблица spb-vsl-gw1

Gateway of last resort is 172.16.2.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.2.0/30 is directly connected, FastEthernet1/0.4
C 172.16.2.4/30 is directly connected, FastEthernet1/1
C 172.16.16.0/24 is directly connected, FastEthernet0/0
S 172.16.17.0/24 [1/0] via 172.16.2.6
S* 0.0.0.0/0 [1/0] via 172.16.2.1

Смотрите, в случае с l3-коммутатором и статической маршрутизации пакеты могут не доходить по трём причинам:
1) проблема с маршрутизацией - один из хостов не знает какую-либо сеть. С этим у вас всё в порядке.
2) где-то стоит ACL, блокирующий трафик. Явно не ваш случай
3) и не запущено процесс маршрутизации. Делается это командой ip routing. Это есть в статье, но видимо, не достаточно заметно)

(no subject) (Anonymous) Expand
(no subject) (Anonymous) Expand
Огромное спасибо за подробное и доступное описание столь сложной темы!!!
При построении сети столкнулся с проблемой: настраиваю маршрутизацию на роутере msk-arbat-qw1 ввожу команду ip route, но когда проверяю show ip route вводимый маршрут не появляется. Никакой ошибки не выводит. В чем дело ума не приложу. Когда ввожу через графический интерфейс аналогично, но в графическом меню этот маршрут появляется. Пинг с московского роутера не проходит. Так не хочется заново настраивать основной роутер. Если возможно помогите...

Скиньте скриншоты команды настройки, интерфейсов и sh ip route. Заново не надо ничего настраивать, я думаю. Можете ещё конфиг.

(no subject) (Anonymous) Expand
Два вопроса: во-первых, появляется ли эта команда в конфиге (sh run). Во-вторых, есть ли пинг c msk-arbat-gw1 на 172.16.2.2?

Спасибо!!! Простите за беспокойство! Как оно добавит маршрут к неизвестному хосту... Нужно было отойти от стола... Может бы сам увидел... Это же надо...

Всегда пожалуйста) Удачи.

Доброго времени суток!
Извините за неуместный вопрос. Но никик не могу добиться пинга между PB-VSL-asw1 (172.16.16.2) на SPB-VSL-gw1 (172.16.16.1) и обратно. Если на СПБ-VSL-asw1 не прописывать IP-адрес то с ПК пинг на СПБ-VSL-gw1 и дальше идет нормально. И ещё у Вас на СПБ-VSL-asw1 Влан 1 в статусе up. Заранее спасибо за ответ.

Плохо понял проблему. Конфиги в студию и схему. И что вы имеете ввиду под "Если на СПБ-VSL-asw1 не прописывать IP-адрес то с ПК пинг на СПБ-VSL-gw1 и дальше идет нормально". А если прописать, то не будет?

(no subject) (Anonymous) Expand
(no subject) (Anonymous) Expand
(no subject) (Anonymous) Expand
Вы уж извините за непонятливость, но вот хотели новичков - нате, получите :)
Можно поподробнее про пинги до сети управления?
Прочитал Ваш диалог с Денисом, понял, что дело в коммутаторах, но не понял физику процесса - почему коммутатор, получив пакет-запрос на IP-адрес сети управления не высылает обратно ответ отправителю запроса. Или вообще всё не так?
За статьи огромное спасибо. Перехожу к четвертой части.
Дмитрий.

Дмитрий, ответ очень простой. Свитч просто не знает куда слать ответ. У него нет маршрута по умолчанию. Как только вы его добавите, все заработает.

(no subject) (Anonymous) Expand
Почему не пингуются хосты управления? Например с компа PTO2 не пингуется адрес 172.16.1.2. Хотя 172.16.1.1 пингуется. И как тогда управлять сетью, если нет доступа к устройствам? Можно конечно настроить 2 влан на аксес порту и подключить туда комп для управления, но это какие-то костыли.

Этот вопрос является домашним заданием данного выпуска. По идее вы самостоятельно должны были найти ответ на него.
Разумеется, никаких костылей тут быть не должно - IP доступность - это базовый функционал любого сетевого оборудования.
Подсказка: куда будет слать коммутатор пакеты в неизвестную сеть?
Если не получится, напишите мне на почту.

Здравствуйте, Эукариот! Я хочу поблагодарить Вас и всех тех кто принял участие в данном проекте за эти ценные статьи! Я желаю Вам и вашим соратникам дальнейших успехов, побольше гениальных мыслей и способов их реализации! Жду еще (статей или проектов:)

Здравствуйте, Гульназ :)
Спасибо за тёплые слова.

Следующая статья 22-го декабря. MPLS L3VPN.
А в наступающем году мы планируем один интересный проект. Будут анонсы.